当前位置: 萬仟网 > 移动技术>移动开发>Android > 5张图片解决android studio报错:Failed to resolve: com.android.support:appcompat-v7:29

5张图片解决android studio报错:Failed to resolve: com.android.support:appcompat-v7:29

2020年12月30日  | 萬仟网移动技术  | 我要评论
android studio已经问世多年了,但是对于刚接触android studio的小伙伴来说,经常会遇到这样的报错:Failed to resolve: com.android.support:appcompat-v7:29 ,如图所示:我今天新建了一个安卓项目也出现了这样子的错误,遇到这样的问题不要慌,看完下面的步骤就可以解决了!第一步:报错了,先去查看以下自己sdk tool 的版本是多少,通过下图可以查看到我的sdk tools的版本号为26.1.1第二步,接下来就要 看看SDK 构建

android studio已经问世多年了,但是对于刚接触android studio的小伙伴来说,经常会遇到这样的报错:Failed to resolve: com.android.support:appcompat-v7:29 ,如图所示:
在这里插入图片描述
我今天新建了一个安卓项目也出现了这样子的错误,遇到这样的问题不要慌,看完下面的步骤就可以解决了!

第一步:报错了,先去查看以下自己sdk tool 的版本是多少,通过下图可以查看到我的sdk tools的版本号为26.1.1
在这里插入图片描述
第二步,接下来就要 看看SDK 构建工具的版本了,具体查看步骤如图所示:
在这里插入图片描述
我找到了sdk 路径是在D盘,我就安装了26.0.1 跟30.0.2 这两个,如图所示:
在这里插入图片描述
然后,我们到打开app里面的build.gradlle文件瞧瞧,更改里面的几个地方就可以了,将compileSdkVersion ,targetSdkVersion的版本号改为跟sdk build tools就好了,保持26这个一样的版本就🆗了。l
在这里插入图片描述
以下这个地方也要改成26(同样是在app 里面的build.gradle文件里面),如图所示:
在这里插入图片描述
最后,点击Try again 就完成了,重新编译下就不会报:Failed to resolve: com.android.support:appcompat-v7:29 这个错误了。
在这里插入图片描述
下次遇到什么疑难问题,不要慌,可以多找找度娘,一定会解决的。好了,看看我运行起来的hello world 吧! 你遇到过这个的异常吗?你是怎么解决的,欢迎留言一起分享!
在这里插入图片描述

本文地址:https://blog.csdn.net/szlihuang/article/details/111942179

如您对本文有疑问或者有任何想说的,请点击进行留言回复,万千网友为您解惑!

相关文章:

验证码:
Copyright © 2017-2021  萬仟网 保留所有权利. 粤ICP备17035492号-1
站长QQ:2386932994 | 联系邮箱:2386932994@qq.com