当前位置: 萬仟网 > IT编程>开发语言>.net > Xcode报错 Unable to install “xxxx”

Xcode报错 Unable to install “xxxx”

2020年08月01日  | 萬仟网IT编程  | 我要评论
一、错误截图如下:二、解决方法:1、尝试过更新证书和检查bundle ID的唯一性,但是还是报上述错误,如果是证书和bundle ID的问题,可以参考文章:https://blog.csdn.net/weixin_38798865/article/details/1031522882、网上说的大部分方法都尝试了,都是依然还是报上述错误,坑爹啊!!!3、先保证模拟器能运行起来,结果模拟器和真机运行报错提示还不一样,有戏啊。。。4、模拟器运行报错如下:5、现在..

一、错误截图如下:

 

二、解决方法:

1、尝试过更新证书和检查bundle ID的唯一性,但是还是报上述错误,如果是证书和bundle ID的问题,可以参考文章:

https://blog.csdn.net/weixin_38798865/article/details/103152288

2、网上说的大部分方法都尝试了,都是依然还是报上述错误,坑爹啊!!!

3、先保证模拟器能运行起来,结果模拟器和真机运行报错提示还不一样,有戏啊。。。

4、模拟器运行报错如下:

 

5、现在终于看到报错提示的有效信息了“AMapFoundationKit.framework”,发现导入AMapFoundationKit(高德地图的SDK)设置嵌入方式不对;应该成Do not embed(不嵌入)方式;

6、终于解决问题了,模拟器和真机都可以正常运行。

三、总结

1、Xcode报错 Unable to install “xxxx”有可能是第三方嵌入方式设置不对;

 

 

 

 

 

 

本文地址:https://blog.csdn.net/pjf_1806339272/article/details/108142474

如您对本文有疑问或者有任何想说的,请点击进行留言回复,万千网友为您解惑!

相关文章:

验证码:
Copyright © 2017-2021  萬仟网 保留所有权利. 粤ICP备17035492号-1
站长QQ:2386932994 | 联系邮箱:2386932994@qq.com